LabVIEW чудит при использовании lvlibp

Создание приложений, библиотек, инсталляторов
Ответить
Аватара пользователя
ladik

Silver
adviser
adviser
Сообщения: 246
Зарегистрирован: 18 ноя 2014, 11:45
Награды: 1
Репутация: 0
Версия LabVIEW: 2011, 2015
Откуда: Астана
Контактная информация:

LabVIEW чудит при использовании lvlibp

Сообщение ladik »

Коллеги, приветствую!

Создаю в LabVIEW 2010 библиотеку lvlibp (порядка 500 VI, включая классы), добавляю её в проект и LV начинает чудить - зависает, крашится и т.д. Кто-то сталкивался с подобным? Мне что-то кажется, что LV10 сыроват для таких задач, но использование этой версии продиктовано заказчиком и от этого мне не уйти.
Дорогу осилит идущий.

Аватара пользователя
taras_33

Activity
professional
professional
Сообщения: 343
Зарегистрирован: 31 окт 2009, 18:25
Награды: 1
Репутация: 0
Версия LabVIEW: 2019
Контактная информация:

Re: LabVIEW чудит при использовании lvlibp

Сообщение taras_33 »

Я использую PPL содержащие классы, причем динамически их подгружая. Проблем подобного рода не наблюдал. Правда это было и есть LabVIEW 2016 в прошлом и 2019 в настоящем.
Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots.
So far, the Universe is winning!

Аватара пользователя
ladik

Silver
adviser
adviser
Сообщения: 246
Зарегистрирован: 18 ноя 2014, 11:45
Награды: 1
Репутация: 0
Версия LabVIEW: 2011, 2015
Откуда: Астана
Контактная информация:

Re: LabVIEW чудит при использовании lvlibp

Сообщение ladik »

taras_33, спасибо за информацию. Пока не нашёл решение, просто не включаю библиотеку в проект, а её функции верхнего уровня вызываю с помощью Call By Reference.
Дорогу осилит идущий.

Ответить

Вернуться в «Создание приложений»