LabVIEW чудит при использовании lvlibp

Создание приложений, библиотек, инсталляторов

LabVIEW чудит при использовании lvlibp

Postby ladik on 17 Sep 2019, 17:52

Коллеги, приветствую!

Создаю в LabVIEW 2010 библиотеку lvlibp (порядка 500 VI, включая классы), добавляю её в проект и LV начинает чудить - зависает, крашится и т.д. Кто-то сталкивался с подобным? Мне что-то кажется, что LV10 сыроват для таких задач, но использование этой версии продиктовано заказчиком и от этого мне не уйти.
Дорогу осилит идущий.
User avatar
ladik
adviser
adviser
 
Posts: 237
Joined: 18 Nov 2014, 11:45
Location: Астана
Medals: 1
Silver (1)
LabVIEW Version: 2011, 2015
Karma: 88
hardware I/O VIP

Re: LabVIEW чудит при использовании lvlibp

Postby taras_33 on 17 Sep 2019, 18:52

Я использую PPL содержащие классы, причем динамически их подгружая. Проблем подобного рода не наблюдал. Правда это было и есть LabVIEW 2016 в прошлом и 2019 в настоящем.
Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots.
So far, the Universe is winning!
User avatar
taras_33
professional
professional
 
Posts: 310
Joined: 31 Oct 2009, 18:25
Medals: 1
Activity (1)
LabVIEW Version: 2019
Karma: 138
CLD VIP

Re: LabVIEW чудит при использовании lvlibp

Postby ladik on 19 Sep 2019, 16:41

taras_33, спасибо за информацию. Пока не нашёл решение, просто не включаю библиотеку в проект, а её функции верхнего уровня вызываю с помощью Call By Reference.
Дорогу осилит идущий.
User avatar
ladik
adviser
adviser
 
Posts: 237
Joined: 18 Nov 2014, 11:45
Location: Астана
Medals: 1
Silver (1)
LabVIEW Version: 2011, 2015
Karma: 88
hardware I/O VIP


Return to Создание приложений

Who is online

Users browsing this forum: No registered users and 0 guests

cron