Labview 22Q3 и Ubuntu 22.04 LTS

Обсуждение программ, пользовательского обеспечения, операционных систем
Ответить
Аватара пользователя
toshas
assistant
assistant
Сообщения: 105
Зарегистрирован: 05 апр 2009, 22:45
Версия LabVIEW: 9.0
Благодарил (а): 13 раз
Поблагодарили: 7 раз
Контактная информация:

Labview 22Q3 и Ubuntu 22.04 LTS

Сообщение toshas »

При попытке установить возникает ошибка о нехватке пакетов, которые нельзя доустановить т.к. для этого нужно понижать версии зависимостей:
libncurses5 libldap-2.4-2
Проблему признали и исправили исключив устаревшие пакеты из зависимостей
https://www.ni.com/en-lb/support/docume ... ssues.html
Решается установкой ni-hwcfg-utility из пакета драйверов 22Q4 (NI Linux Device Drivers 2022 Q4)
В итоге все работает на Ubuntu 22.04 LTS корректно, включая Wayland Desktop который в 22.04 идет по умолчанию.
Аватара пользователя
IvanLis

Activity Professionalism Tutorials Gold Man of the year 2012
Автор
guru
guru
Сообщения: 5462
Зарегистрирован: 02 дек 2009, 17:44
Награды: 7
Версия LabVIEW: 2015, 2016
Откуда: СССР
Благодарил (а): 28 раз
Поблагодарили: 86 раз

Re: Labview 22Q3 и Ubuntu 22.04 LTS

Сообщение IvanLis »

Нашел время для экспериментов.
При установке VISA/DAQ вылетает ошибка
E: ni-visa-passport-pxi-dkms: подпроцесс из пакета ni-visa-passport-pxi-dkms установлен сценарий post-installation возвратил код ошибки 10
E: ni-visa-passport-pxi: проблемы зависимостей — оставляем не настроенным
пока нет времени, если найду как побороть, отпишусь
Аватара пользователя
IvanLis

Activity Professionalism Tutorials Gold Man of the year 2012
Автор
guru
guru
Сообщения: 5462
Зарегистрирован: 02 дек 2009, 17:44
Награды: 7
Версия LabVIEW: 2015, 2016
Откуда: СССР
Благодарил (а): 28 раз
Поблагодарили: 86 раз

Re: Labview 22Q3 и Ubuntu 22.04 LTS

Сообщение IvanLis »

К стати для Linux-оидов :crazy:
Нормально запускаемый 64-bit VIPM:
https://forums.vipm.io/topic/6423-annou ... ublic-beta
А то эти пляски с бубном и 32-bit пакетами утомляла
Ответить
  • Похожие темы
    Ответы
    Просмотры
    Последнее сообщение

Вернуться в «Софт»